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OVERVIEW

If you choose to manipulate data using Microsoft Office Excel it is important that you
import the file into Microsoft Excel® using the Data Import Wizard. If you do not follow
the procedure explained in this document, Excel may alter your data. This document
applies to the following versions of Excel:

Excel 2010

Excel 2013

Excel 2016

Excel 2019

Where there are differences between versions in the instructions and/or screen shots,
the specific version(s) that apply are noted. If the version of Excel is not noted, then
the instructions and/or screen shots apply to all versions.

If you open a text formatted file in Microsoft Office Excel, Excel makes assumptions
regarding the contents of a file, and manipulates the data according to those
assumptions. For example, leading zeros are deleted and date formats may change.
Furthermore, Excel does not alert or notify the user regarding the changes which have
been made to the data.

Therefore, in order to preserve the integrity of the data, it is critical to import the file
into Excel. This is best accomplished using the Data Import Wizard, which preserves the
text formatting of your file. By using this wizard, external data can be imported and the
original formatting is unchanged. Follow the steps in this document if you want to use
Excel to manipulate your data.

IMPORTING DATA INTO EXCEL AS TEXT

For Excel 2019 - Select Data > Get Data - From File > From Text/CSV
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Import data from a text file.

For Excel 2010 - Select Data > From Text
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Acrobat

Data Review View

I:! (@ Press F1 for more help.

The Import Text File pop up window displays. Locate and select the file to import and

click IMPORT.
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File name: Student

= 0 @
Date modified Type Size

6/22/201112:11 PM  Microsoft Office E... 26 KB

v [TextFiles -

Tools - [ Import |v] ’ Cancel ]

NOTE: You may have to navigate to the directory that holds your data. Consult
Excel documentation for additional information on navigation.

Import Wizard with Excel 2019
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In Excel 2019 the Imported File Window displays. Click the DELIMITER drop down to
select the files delimiter type. Then click the DATA TYPE DETECTION drop down. You can
choose to use the auto detected data types for each column based on the first 200
records in the text file or the entire file. Once you have selected the detected type click
LoAD to complete the import process.

sample.csv
File Origin Delimiter Data Type Detection
1252: Western European (Windows) ~ Comma - Based on first 200 rows - (=3

Based on first 200 rows

Columnl  Column2 Column3 Column4  ColumnS  Columné ‘Columny
Based on entire dataset
17000476 888 10200 | Yes No Maybe a5/}
Do not detect data types
17002972 823 24| Yes No Maybe H12/5015 s
17005468 758 250  Yes No Maybe 4/19/2018 | Yes
17007964 693 443 Yes No Maybe 19 | Yes
17010460 628 567 Yes No Maybe 19 | Yes
17012956 563 1214350 | Yes No Maybe Yes
17015452 498 45| Yes No Maybe Yes
17017948 433 75000 | Yes No Maybe 5/24/2019 | Yes
17020422 s68 546 | Yes No Maybe 5/31/2019 | Yes

[ oaa [-] Eait Cancel

If you want to manually define the column data types select DO NOT DETECT DATA TYPES
from the drop down then click EDIT.

The Query Editor Window will open.

| @&~ = | sample - Power Query Editor o %
Home Transform Add Column View ]

[i Properties L Yy s 2 Y Data Type: Whole Number ~ New Source ™
g 22 ¥ BB L= = C
LT sdvanced Editor Zl [ Use First Row as Headers ~ [ Recent Sources -
Close &  Refresh Choose Remove  Keep Remove Split  Group Combine Manage  Datasource
Load~  Preview~ [Z] Manage ~ Columns ~ Columns~  Raws = Rows ™ Column~ By o2 Replace Values - Parameters ~ settings
Close Query Manage Columns Reduce Rows  Sort Transform Parameters  Data Sources New Query
> . 1123 Columnl [ -]12; Columnz [~ Column3 [~ ||Af Columns [~ AR columns [~|A% columns [~ Column? [~ A8 Columnt| (), €
A 1% 12 I 2 e E e Query Settings X
P 1 17000475 238 10200 Yes No Maybe 4/5/2019 Yes
T 2 17002972 822 24| Yes No Maybe 4/12/2019 Yes 4 PROPERTIES
g3 17005468 758 250 Yes No Maybe 4/18/2019 Yes Name
4 17007964 693 443 | Yes No Maybe 4/26/2019 Yes sample
5 17010460 628 567 Ves No Maybe 5/3/2019 Yes Al Properties
6 17012856 563 1214350 Yes No Maybe 5/10/2019 Yes
7 17015452 498 45 Yes No Maybe 5/17/2019 Yes 4 APPLIED STEPS
8 17017948 433 75000 Yes No Maybe 5/24/2019 Yes Source
9 17020444 368 345 Yes No Mayhe 5/31/2019 Yes X Changed Type
< >
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To set each column data type click on the column header then click on the Data Type drop
down and select the column data type. Once this has been done click on Close & Load.

| &+ = | sample - Power Query Editor O %
Home Transform Add Column View
'

5 [:2 Properties L Y K G| 1 = [ New Source ~
& C HE L= 5 E

N > -
#4  [Z} Advanced Editor F) Decimal Number [ Recent Sources +
Close & Refrash Choose  Remove  Kesp Remove Split  Group Combine  Manage  Datasource
Load~  Preview= ) Manage ~ Columns ~ Columns > Rows~ Rows ™ Column~ By Currency - Parameters ~ settings
Close Query Manage Columns Reduce Rows  Sort Whole Number Parameters  Data Sources New Query
s @ 5 5 5 Percentage t 5
. |12 Columnl [ -|+% Column2 [-]|12 Column3 |~ | A% Columnd [~ AB. Columns iolumn? [ ~|/A% Columng Ler
Date/Time F Quiery Settings X
P 1 17000476 £58 10200 Yes No 4/5/2019 Yes
T 2 17002972 £23 24 ves No pate 4/12/2019 Yes 4 PROPERTIES
© 3 17005468 758 250 ves Ne Cne 4/19/2019 Yes Name
4 17007964 693 443 Yes No Date/Time/Timezone 4/26/2019 Yes sample
. Duration .
5 17010460 628 567 Yes No 5/3/2019 Yes All Properties
8 17012656 563 1214350 Yes No Test 5/10/2019 Yes
7 17015452 498 45 Yes Ne True/False 5/17/2019 Yes 4 APPLIED STEPS
8 17017548 433 75000 Yes No Binary 5/24/2019 Yes Source
[ 17020484 368 345 Yes No Waybe 5/31/2019 Yes X Changed Type

Once this has been done for each column click on Close & Load.

= RB¥E-B 3 = Books - Excel i
Fle  Home Insert Pagelayout  Formulas  Data  Review  View  Developer  Help
AL v f- || Column1
A 8 c D E F G H
1 |columni| ~ | Column2| | Column3 | | Column4| =] Columns [~ | Column6 [~ | Column7 [~ | Columns [~
2| 17000476 888 10200 Yes No Maybe 4/5/2013 Yes
3 17002972 823 24 Yes No Maybe 4/12/2019 Yes
4 17005468 758 250 Yes No Maybe 4/19/2019 Yes
5| 17007964 693 443 Yes No Maybe 4/26/2019 Yes
6 | 17010460 628 567 Yes No Maybe 5/3/2019 Yes
7 17012956 563 1214350 Yes No Maybe 5/10/2019 Yes
8 17015452 498 45 Yes No Maybe 5/17/2019 Yes
9| 17017948 433 75000 Yes No Maybe 5/24/2019 Yes
10| 17020444 368 346 Yes No Maybe 5/31/2019 Yes |
1 ]

To Import for all other versions of Excel follow instructions below.

The Text Import Wizard pop up window displays.

eScholar LLC

eScholar Guide to Importing Data in Microsoft Excel® - Revision 1.0
Confidential and Proprietary Property of eScholar LLC ©2005-2022. All Rights Reserved.

Page 6



i eScholar

Text Import Wizard - Step 1 of 2 (B

The Text Wizard has determined that your data is Delimited,
If this is correct, choose Mext, or choose the data type that best describes your data.

Original data type

Choose the file type that best describes your data:
0 - Characters such as commas or tabs separate each field.

(7)) Fixed width - Fields are aligned in columns with spaces between each field.

Startimportatrow: |1 =] File origin: 437 : OEM United States [~]

Preview of file C:\UsersYgjones\DesktopiTest\Student. csv.

District code,Location code, School year date, Student ID,Social Security j +
n1,4,2011-06-30,1,,,,,. Yooos0000060000050 B o6 00000000000 500600600000060
ni,4, 2011-06-30,2,,,

1,4,2011—06—30,3, coo
N1,4, 2011-06-30,4, ., ., Tvvvererrrrrrenreeecererrrarsenraereersaseenrenn -

TIP: Use this screen to define the file characteristics (delimited or fixed width). In
the example above, the data type is Delimited.

NoOTE: As demonstrated in the Preview section above, the data type is defined as a
Delimited file.
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Click NEXT. The second pop up window of the Text Import Wizard displays.

Text Import Wizard - Step 2 of 3

B[

below.
Delimiters
[] Semicolon [7] Treat consecutive delimiters as one

Comma . |z|

Text gualifier:
|:| Space
] other:

Data preview

This screen lets you set the delimiters your data contains. You can see how your text is affected in the preview

istrict_code [Location_code School year date Btudent ID Socizl Security nug ~

1 011-0&-30
1 011-0&-30
1 011-0&-30
1 011-0&-30 -
4 2
l Cancel II < Back J[ MNext = ]I Einish J

NoTE: This is an illustration of the second step of the wizard for a Delimited file type.
This particular file is defined as a CoMMA DELIMITED file. To change the selected
DELIMITER, click the value of DELIMITER used to separate the fields in your file.

Text Import Wizard - Step 2 of 3

This screen lets wou set Field widths {column breaks),

2]

Lines with arrows signify a column break.
To CREATE a break line, dick at the desired position.

To DELETE a break line, double dlick on the line.
To MOYE a break line, click and drag it.

rData preview

10 pall] 30 40

50 &0

- 3 Iy

P2099299,001,F003-06-30, 1005E7, ", ", Al exands

Pistrict Code|,Location Id,School Tear,Student| Id,Student Ssn,Fsmiﬂ
T2099993 001 ,E003-06-230, 100555, ", """ Hannouchle , Sandy, """, 09,09 ,9ch

20999293 082 FO03-06-30, 100582, ", """ Ehu,Igrah,"",10,10,10ch,"" 1
T3092599%3 001 ,E003-06-30, 100561, """, "" Jones, Judith,"" ,11,11,11th,"

p Isabella, ", 11,11, ||

ST

Cancel < Back

o
Einish |
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NoOTE: This is an illustration of the second step of the Data Import Wizard when you
are importing a FIXED WIDTH data file. The lines with arrows in the Data Preview
indicate a column break.
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Click NEXT. The third pop up window of the Text Import Wizard displays.

ki Sk fu Eilt Diata Tonl

& Text Import Wizard - Step 3 of 3 -2 [

This screen lets you select each column and set the Data Format.

F_I'I

Column data format

~) General

‘General' converts numeric values to numbers, date values to dates, and all
remaining values to text.

Opme bor 3]

() Do not import column (skip)

Data preview

S5 T5-W S e - M =15

eR L P ccation code Pchool yesr date Student ID Pocizl Securicy nug +

Eol1-06-30 il (3
EO11-08-30 E
EOL1-08-30 B
EO11-06-30 e -
r
o ) [ ]

NoOTE: This is an illustration of the third step of the Data Import Wizard. Regardless
of the Data Type of your file, it is critical to select TEXT as the COLUMN DATA
FORMAT. This preserves the formatting of numeric values in your file.

Tip: Click the first column of data in DATA PREVIEW to select all data fields.
Press and hold the SHIFT key. Click the last column. All rows in DATA PREVIEW
are selected.
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Text Import Wizard - Step 3 of 3 R

This screen lets you select each column and set the Data Format.

Column data format

al
‘General converts numeric values to numbers, date values to dates, and all

remaining values to text.

we (01 [

Do not import column (skip)

Data preview

Click FINISH. The Import Data pop up window displays.

(Import Data pop up window in Excel 2013 and Excel 2016)

— N

Import Data X

Select how you want to view this data in your workbook.
D Table
ﬂ PivotTable Report
5| PivotChart
D COnly Create Connection
Where do you want to put the data?
@) Euxisting worksheet:
=5A51 (2|

MNew worksheet

Add this data to the Data Model

Properties... | [ QK l ‘ Cancel ‘
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(Import Data pop up window in Excel 2010)

Import Data l ¥ |ﬁ|

Where do you want to put the data?
(@ Existing worksheet:

s
) Mew worksheet
Properties. .. ] [ (0] ] [ Cancel ]

Select EXISTING WORKSHEET to return the data to the spreadsheet in which you started.
Click OK. An Excel spreadsheet displays with the imported data.
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Home Insert Page Layout Formulas Data Review View Acrobat
@ [E5) connections Al ? {x Clear E_.E
L o B ﬁ' Properties ‘ EiA -';;- Reapply
F'jm.- Iir;:um From F|'-3m_f_:)trher Existin_g ) Refrevsh g %l Sort Filter \"()Advanced Text to Ren'_lq
Access  Web Text Sources Connections Al Columns Duplic
Get External Data Connections Sort & Filter
ES - £ |
A B C D E F (
1 |District_code Location_code School_year_date Student_ID Social_Security_number FamilyNumber Last_Nan
2 |11 4 2011-06-30 1
3 |11 4 2011-06-30 2
4 11 4 2011-06-30 3
5 |11 4 2011-06-30 4 I I
6 11 4 2011-06-30 5
7 |11 4 2011-06-30 6
& 11 4 2011-06-30 7
9 11 4 2011-06-30 8
10 (11 4 2011-06-30 9
11 (11 4 2011-06-30 10
12 |11 4 2011-06-30 11
13 |11 4 2011-06-30 12
14 |11 4 2011-06-30 13
15 (11 4 2011-06-30 14
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Select FILE - SAVE As. The Save As dialog box displays.

2| Recent Places

4l Libraries
=l ARIS
3 Documents
J'- Music

[ Save As @
@uv| J b Test - | *4 ||| Search Test ol
Organize « Mew folder == - I@l

i MName Date modified Type Size
. Favorites = = =
uden 6/22/ : v Microso iceF...
Tt E2] Student 6/22/2011 218 PM = M ft Office E
esktop
& Downloads 3

. - 4
| Pirtures |

File name: Student

I 2

Save as type: | CSV (Comma delimited)

Authors: Kim Jones

* Hide Folders

Tags: Add atag

Tools - Save l ’ Cancel ]

Select CSV (coMMA DELIMITED) from the SAVE As TYPE drop down box. Enter an
appropriate file name in the File Name field and navigate to the directory into which
you wish to save the file. Click SAVE to save the file in comma-delimited format.

NOTE: This step is critical if you have manipulated the contents of the file in
Microsoft Office Excel. This ensures the changes you made to the data are saved to

the imported file.
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